Page 1 of 1

Issue with CodeHealer under DXE8

Posted: Mon May 25, 2015 12:39 am
by ijbranch
Hi Guys,

Been playing with CodeHealer with my DX8 project.

Got an interesting report....
Missing conditional symbol in directive at column 75 in line 7874 in
the file
'c:\program files(x86)\embarcadero\studio\16.0\source\rtl\win\'

function LoadLibrary(lpLibFileName: LPCWSTR): HMODULE:{$IF Declared(System.Embedded)} inline; {$ELSE} stdcall; {$ENDIF}

Would you like to edit this file in Delphi..


I don't get this under DXE7.

Anybody else see this? Is this a false reading/response?



Re: Issue with CodeHealer under DXE8

Posted: Mon Jun 01, 2015 10:52 am
by skaug
hi Ian,

which version of CodeHealer are you using?
AFAIK even the latest release (3.0) doesn't officially support XE8.
If this is blocking you, send a mail to [], as they're not really monitoring the forums very closely nowadays.


Re: Issue with CodeHealer under DXE8

Posted: Wed Nov 25, 2015 4:17 pm
by Support

I am so sorry for the delay in answering your message, I am not sure why we missed it, and thank you Kristofer for accurately answering the question.

That said, we are currently wrapping up testing of CodeHealer 3.1 that fully supports both XE8 and 10 Seattle, with a view to releasing it next month (December), and the issue that you point out is certainly one of the issues that it resolves.

If you are still interested in CodeHealer for XE8 then please drop us an email at and we can get you an up to date version of the trial or Beta that supports XE8.

Apologies again for missing this message until now.

Best regards,